hat jmd kingbright 7x5 dot matrizen (TA07,TA20) ausprobiert?

hier kann alles besprochen werden, was ARCADEmini betrifft - siehe http://arcademini.schuermans.info/ oder https://arcademini.schuermans.info/
Antworten
tommy

hat jmd kingbright 7x5 dot matrizen (TA07,TA20) ausprobiert?

Beitrag von tommy » Sa Mai 08, 2004 8:22 pm

Hi,

Mancher Elektronikhändler (etwa reichelt) bietet sog. "Dot Matrix Displays" an. Das sind 7x5 LEDs, deren anoden spaltenweise und deren kathoden zeilenweise vermascht sind. Eigentlich wuerden die sich prima zu einer grossen 20x26 matrix zusammenstacken lassen. Meine versuche schugen allerdings alle fehl, da sich die leds bei hohem stromfluss (150mA) richtung orange/beige/weiss verfaerben. Das erlaubte tastverhaeltnis (1/10 duty cycle laut datenblatt) halte ich ein.

Kann zufaellig jmd meine beobachtung bestaetigen? Was mache ich falsch? Wie kriege ich das schone blutrot zurueck?

Daten nochmal ganz präzis: LEDs werden 100usec eingeschaltet, dann 900usec aus, usw. Vorwiderstand zwischen 47 ohm und 0 ohm variiert.
Die verfaerbung ist panel-unabhaengig (ich habe 6 stueck ausprobiert).
Genau typbezeichnung: TA20-11HWA

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » So Mai 09, 2004 9:33 am

Ich denke mal, dass 150mA einfach zuviel ist, auch bei 10% Tastverhältnis. Im Datenblatt steht ja, dass der Strom für Normalbetrieb 10mA ist, also werden bei 10% Tastverhältnis maximal 100mA erlaubt sein.

Das sich LEDs bei Überstrom verfärben ist glaube ich normal, da dann die Elektronen im Halbleitermaterial nicht nur um eine, sondern gleich um zwei oder mehr Elektronenschalen angehoben werden und dann beim zurückfallen in ihre Ausgangsschale mehr Energie abgeben müssen. Und eine höhere Energie bedeutet eine höhere Frequenz, d.h. eine andere Farbe...

Gast

Beitrag von Gast » So Mai 09, 2004 10:46 am

Das datenblatt (etwa bei reichelt downzuloaden, wenn man nach TA20 sucht und sich durchklickt) gibt definitiv an:

Peak Forward Current 150 mA (bei 1/10 duty cycle, 0.1ms pulse width)

Das halte ich eigentlich ein (mit dem scope habe ich timing sogar nachgeprueft).

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » So Mai 09, 2004 10:06 pm

Diese Angabe heisst "peak current" und steht bei den "absolute maximum ratings". D.h. das ist der Strom, bei dem de Dinger gerade noch nicht durchbrennen. Dass sich die Farbe ändert liegt eben an dem oben geschilderten Effekt, da kann höchstens der Hersteller etwas dran ändern, indem er andere Halbleiterstoffe verwendet oder so...

Warum gehst Du nicht einfach so weit mit dem Strom runter, bis die LEDs wieder rot sind? Wenn es Dir dann nicht hell genug ist, wirst Du andere LEDs verwenden müssen...

Hast Du eigentlich vor, mit diesem Matrix-Bausteinen ein ARCADEmini zu bauen, oder bastelst Du an einem völlig eigenen Design?

tommy

Beitrag von tommy » Mo Mai 10, 2004 11:16 am

1stein hat geschrieben:Diese Angabe heisst "peak current" und steht bei den "absolute maximum ratings". D.h. das ist der Strom, bei dem de Dinger gerade noch nicht durchbrennen. Dass sich die Farbe ändert liegt eben an dem oben geschilderten Effekt, da kann höchstens der Hersteller etwas dran ändern, indem er andere Halbleiterstoffe verwendet oder so...

Warum gehst Du nicht einfach so weit mit dem Strom runter, bis die LEDs wieder rot sind? Wenn es Dir dann nicht hell genug ist, wirst Du andere LEDs verwenden müssen...
Wenn ich mit dem strom runtergehe, wird das display zu dunkel. Wenn ich meine deckenlampe (60W) nicht abschalte, muss man genau hinschauen, wenn das display auf dem tisch liegt und man was erkennen moechte.

Andere LEDs behalten bei den 160mA ihre farbe (ich habe normale und LC ausprobiert). Ich wollte aber gerade um die arbeit herumkommen, diese einzeln einloeten (und ausrichten!) zu muessen.

Weshalb ich die idee mit den 5x7-modulen noch nicht aufgeben moechte:
Diese sind an einigen stellen im reallive auch verbaut (etwa in der fahrstuhlanzeige im lokalen karstadt). Dort leuchten sie super (und hell trotz deckenbeleuchtung). Ich versuche gerade rauszukriegen, wie die das gemacht haben. [Ob das alles an dem roten plexiglas liegt, das die davor montiert haben?]
1stein hat geschrieben: Hast Du eigentlich vor, mit diesem Matrix-Bausteinen ein ARCADEmini zu bauen, oder bastelst Du an einem völlig eigenen Design?
Beides. Es wird ein eigenes design (AVR-based, PC-autark). Wie gross das display wird (20x26 vs 8x18) ist jedoch noch nciht entschieden.

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Mo Mai 10, 2004 11:39 am

Nunja, wenn Du Dir sicher bist, dass Du das Timing und den Strom von 150mA einhälst, dann ist wohl entweder das Datenblatt falsch oder Du hast defekte LED-Bausteine erhalten. Ich kann mir jedenfalls nicht vorstellen, was da noch falsch sein sollte, wenn Du den Strom und das Timing gemessen hast...
Beides. Es wird ein eigenes design (AVR-based, PC-autark). Wie gross das display wird (20x26 vs 8x18) ist jedoch noch nciht entschieden.
Also kein ARCADEmini...

Benutzeravatar
ST
BlinkenProfi
BlinkenProfi
Beiträge: 93
Registriert: Mo Jun 23, 2003 8:26 pm
Wohnort: Stuttgart
Kontaktdaten:

Beitrag von ST » Mi Mai 26, 2004 12:35 pm

Hi Tommy,

> Ich wollte aber gerade um die arbeit herumkommen, diese einzeln
> einloeten (und ausrichten!) zu muessen.

Ich bin der Meinung du verplämperst damit deine Zeit. 1stein hat so eine schöne Bohrschablone [1] gemacht und mit der sind 1040 LEDs in einer halben Stunde gebohrt. Durch die Matrixverschaltung ist es auch nicht so viel Lötarbeit. Mit einem ArcadeMini (was auch ohne PC läuft) wärst du jedenfalls schon fertig, wenn ich lese was du schon alles veranstaltet hast. Aber experimentieren ist ja auch gut. Zu diesen LED Zeilen die man überall sieht kann ich nur sagen das dass sehr helle LEDs mit einem kleinen Öffnungswinkel sind. Die werden auch irgendwie speziell angesteuert, ich hab das aber nicht mehr genau im Kopf, glaube die werden mit hohem Strom gepulst.


Viele Grüße

[STephan]

[1] https://wiki.blinkenarea.org/bin/view/B ... MiniAufbau

JensG
EinmalBlinker
EinmalBlinker
Beiträge: 1
Registriert: Sa Mai 27, 2006 10:49 am

Beitrag von JensG » Sa Mai 27, 2006 11:02 am

Es ist wohl besser andere Bauteile zu verwenden. Die von Reichelt angebotenen Dot-Matrix-Display sind recht preiswert, aber sehr dunkel.

Besser sind dann die Module TA20-11EWA die etwa 6x heller sind oder noch besser TA20-11SRWA die etwa 22x heller sind. Die letztere Farbe habe ich bei 7-Segment Leuchtdioden verwendet. Man braucht im Mittel etwa 1,5 mA je Segment bei 100 Hz Refresh.

Mehr als 50 mA Peak würde ich die genannten Leuchtdioden nicht belasten. Bei den Bauteilen von Reichelt bringt ein höherer Strom als 20 mA ohnehin keine Verbesserung der Helligkeit. Das kann man im Datenblatt nachlesen.


Gruss -- Jens Grabner

Antworten