Arcade-Medium-Blue

hier kann alles besprochen werden, was ARCADEmini betrifft - siehe http://arcademini.schuermans.info/ oder https://arcademini.schuermans.info/
zwanzischmark

Arcade-Medium-Blue

Beitrag von zwanzischmark » Di Feb 01, 2005 12:54 pm

So, nach etwas mehr als einer Woche von der Idee bis zur fastigen Fertigstellung hab ich mal ein paar Bilder von meinem Projekt gemacht. Es ist wohl ein zwischending von Maxi und Mini also ein Medium ;) Mit einer Fenstergrösse von 2 x 4 cm ergibt sich eine Matrix von 60 x 90 cm die aus einem einzigen Stück Holz gefertigt wurde *g*. Ich konnte mich nicht so wirklich auf die Farbe einigen und schwankte etwas zwischen weiss und blau, weil es rot ja schon oft genug gibt. Naja,.. letztendlich ist es blau geworden....

hier erstmal ein paar Bilder...

Bild

Bild

Bild

Bild

Bild

Bild

und ein Video...

http://www.zwanzischmark.de/arcade/Arcade-Medium.avi

was ich noch fragen wollte: Ich muss zur Zeit ja das ding im Latch Modus betreiben, weil es sonst die bekannten Schatteneffekte gibt. Ich hab noch keine Schalter dran und hab mir das jetzt mal eben über drähte hingefummelt... hab aber gelesen das das auch über USB gehen soll, aber nicht gefunden wie also da wär ne Antwort ganz hilfreich =)

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Di Feb 01, 2005 1:34 pm

Das Umstellen in den Latch-Modus geht mit Hilfe des dem USB-Treiber [1,2] beliegenden Programms "am_usb_test". Dort kann man "help" eingeben und die möglichen Befehle aufgelistet zu bekommen. "out-style-set latch" ist der Befehl zum Umstellen in den Latch-Modus. (Diese Einstellung ist dann dauerhaft gespeichert, bis man es wieder zurückstellt.)

Gruß,
1stein

[1] http://arcademini.schuermans.info/drive ... 25.tar.bz2
[2] http://arcademini.schuermans.info/drive ... -08-25.zip

zwanzischmark

Beitrag von zwanzischmark » Di Feb 01, 2005 4:21 pm

ok danke für die Antwort erstmal...

was ich noch sagen wollte bezüglich der Schatten: nach meiner Amateur beurteilung liegt das an den Transistoren die einfach zu langsam sind bzw. noch Strom durchlassen wenn die nächste Zeile schon geschaltet ist. der Schatten ist also immer ein verschwächtes Abbild der nächsten Zeile... Der verwendete Transistor ist laut Datenblatt auch in sich 2 mal Verstärkt, also der muss in sich selbst schon 2 mal Schalten bis es zur Ausgabe kommt, aber wie auch immer wenn ich nicht zu faul bin werd ich werd mal nach einem anderen suchen und ein bisschen testen und dann berichten ob sich das Problem damit lösen lässt. Im Latch modus funzt es ja auch wunderbar ich denke mal da läuft das ganze etwas langsamer ab?!?...

dann noch ne kleine Frage: würde die USB übertragung noch funktionieren wenn ich die 5+V leitung kappen würde? mir gehts darum das ich das Ganze ding per Netzteil an und ausschalten kann und wenn der PC an ist würde zumindest die Platine immer mitlaufen auch wenn man dann nix sieht macht das wenig Sinn.

meine anderen fragen fallen mir grad nich mehr ein :? ich komm später wieder


Paul

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Di Feb 01, 2005 8:26 pm

Ja, das kann gut sein, dass der Transistor einfach zu langsam ist. Bei der Latch-Ausgabe ist die eingeschaltete Zeit einfach etwas kürzer und dadurch eine kleine Pause zwischen den Zeilen. Damit sind die LEDs ein klein wenig dunkler aber der Schatten ist weg.

Wenn Du einen besseren Transistor findest, würde ich mich freuen, wenn Du darüber hier berichtest.

Wenn man die +5V-Leitung auf dem USB trennt, wenn das Netzteil eingeschaltet ist, dann macht das keine Probleme. Falls aber die Datenleitungen Kontakt haben und die +5V-Leitung nicht während das Netzteil ausgeschaltet ist, dann wird die Platine über die Datenleitungen und die Schutzdioden im USB-Chip mit Strom versorgt. Das überlastet mit Sicherheit die Bustreiber im PC und kann den USB im PC zerstören.
Was ist denn so schlimm daran, dass die Platine bei eingeschaltetem PC mitläuft? So viel Strom braucht die ja nicht.
Und z.B. ein angeschlossener Scanner, der gerade nicht scannt, läuft ja auch mit...

Gruß,
Stefan

zwanzischmark

Beitrag von zwanzischmark » Di Feb 01, 2005 9:04 pm

schlimm ist es natürlich nicht unbedingt, war nur sone idee ;) ich glaub das is ne Art von mir alles ausschalten können zu müssen, aber zur not kann ich ja noch den stecker ziehen *g*

zwanzischmark

Beitrag von zwanzischmark » Do Feb 10, 2005 2:56 pm

hallo,

zuerst wollte ich sagen das das usb-test-dings da bei mir nicht viel macht ausser wieder auszugehen nachdem mans angeklickt hat. Bin wohl zu doof dafür...

so und jetzt zum eigentlichem Thema: wie schon gesagt wollte ich das Ganze mal mit anderen Transistoren versuchen. Gesagt getan, nur hab ich damit leider in die falsche Richtung gearbeitet, denn jetzt hab ich sogar noch im Latch-Modus minimale Schatten. Ich hab den BD 238 genommen wobei ich eigentlich den BD 236 haben wollte, weil der die gleichen Spannungswerte hat wie der TIP 125. Hab aber keine ahnung ob das nen Unterschied macht. Auf jeden Fall kann ich zu dem Ding schonmal sagen das es "noch" langsamer ist als der TIP 125 was für mich zwar unlogisch scheint, aber ich hab auch keine ahnung. Wollte nur mal berichten..... vielleicht hab ich ja noch Gedult weiter zu probieren


Paul

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Do Feb 10, 2005 4:56 pm

Das usb-test-dings ist eine Konsolenanwendung. So etwas klickt man nicht doppelt. Das muss man aus einer Konsole heraus aufrufen. Dann wird man auch die Ausgabe sehen, die einem mitteilt, dass man als Parameter das Device angeben sollte, welches man ansprechen will:

Code: Alles auswählen

C:\Wo\Auch\Immer> AmUsbTest \\.\AmUsb0
Zu den Schatten kann ich leider nichts weiter sagen, da ich da zuerst mal mit einem Oszilloskop messen müsste, was da los ist.
Prinzipiell sperrt ein Transistor schneller, wenn man den Widerstand zwischen Basis und Emiter kleiner macht bzw. den Basiswiderstand zwischen Signalquelle und Basis größer...
Die Schaltzeiten der Transistoren sollten im jeweiligen Datenblatt stehen. Ob sich da die Spannungen drauf auswirken, weiss ich leider auch nicht, denke aber eher dass das nicht so ist...

zwanzischmark

Beitrag von zwanzischmark » Do Feb 10, 2005 6:58 pm

hi,

Also mit den Widerständen hab ich schon einiges ausprobiert z.B. Signal-Basis von 1k auf 4k7 und bei Basis Emiter 10k und 4k7. Bringt aber nur minimale Veränderungen. Jetzt bleibt mir nix anderes übrig als nochmals neue Transistoren zu bestellen. Wenn du mir sagen kannst wo die Schaltzeiten im Datenblatt stehen bzw. wie die halt bezeichnet werden würde mir das sehr helfen, weil ich versteh bei den vielen Werten nur Bahnhof.

Paul

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Do Feb 10, 2005 10:57 pm

Tja, da hab ich wohl vorschnell was behauptet. Ich finde nämlich leider keine Schaltzeiten in den Datenblättern vom TIP125 und vom BD236. Wobei ich auch immer noch nicht glaube, dass das die Schaltzeit alleine das Problem ist...

In Bezug auf die Widerstände kann man ruhig auch mal 1kOhm zwischen Basis und Emitter sowie 4k7Ohm von Basis zur Signalquelle ausprobieren.

Eine weitere Idee ist ein Widerstand vom Kollektor zur Masse, um die parasitäre Kapazität leer zu saugen, wenn der Transistor sperrt. Mal eben rechnen. Laut Datenblatt hat der TIP125 eine "output capacitance" von 300pF. Nun soll die Ladung in 300ns (3 Befehlstakte bei 10MHz Befehlstakt) da weg, das braucht näherungsweise 5 Zeitkonstanten (also Zeitkonstante 60ns). Für die Zeitkonstante gilt tau = R * C, d.h. R = 60ns / 300pF = 200Ohm. Da würden dann bei 5V im Ein-Zustand 25mA durch den Wiederstand fließen, das macht 125mW. Da nur eine Zeile gleichzeitig an ist, multipliziert sich das nicht mit 20, damit kann man leben. Also zusammengefaast vom jedem TIP125-Kollektor ca. 200Ohm gegen Masse kannst Du auch mal probieren ;)

Ich wollte ja eigentlich auch so eine Verstärker-Schaltung basteln um das mal endlich ordentlich hinzubiegen, aber ich hab im Moment keine Zeit eine Matrix mit normalen LEDs zu löten...

An sich ist aber am Latch-Timing nichts schlimmes dran, nur die LEDs sind ein ganz klein wenig dunkler. Ich werde aber mal sehen, ob ich noch ein Amplifier-Timing in die Firmware einbauen kann, welches auf die Verstärkerschaltung zugeschnitten ist. Da wäre dann das Timing nicht so knapp ausgereizt, wie beim LED-Timing, aber auch nicht so auf Sicherheit, wie beim Latch-Timing...

Viele Grüße,
Stefan

EDIT: Ich habe das Amplifier-Timing mal eingebaut. Neue Firmware und neuer Treiber sind auf dem Server:
http://arcademini.schuermans.info/firmware_de.html
http://arcademini.schuermans.info/drivers_de.html

zwanzischmark

Beitrag von zwanzischmark » Fr Feb 11, 2005 10:39 am

hi,

also deine Rechnung ist beeindruckend ;), aber um weiterzumachen wag ich mich an einen letzten Versuch einen anderen Transistor zu testen, denn es ist jetzt zumindest absolut sicher das der BD*** langsamer ist als der TIP125 und da ich keinen bock hab nochmal die ganze Platine umzulöten brauch ich jetzt einen den ich einfach durch den jetzigen tauschen kann. Die Sache Kollektor gegen Masse hört sich auf jeden Fall sehr logisch an. Also wenn ich diemal nich selbst Glück hab kannste mir das ja nochmal für den neuen ausrechnen. Der BD*** steht in der Kategorie Standart Leistungstransistoren, der TIP unter Darlington Leistungstransistoren. Ob das jetzt was über die Qualität aussagt ist natürlich fraglich, aber wenn ich jetzt noch einen vom selben Hersteller nehme sollte der zumindest nicht schlecher sein als der TIP. Ich bin deshalb diesmal beim BD678 gelandet, also wünsch mir Glück das das mehr bringt ;).

Warum ich das mache ist sicher ne Frage die man stellen darf, weil es ja im Latch-Modus eigentlich super funktioniert. Du kannst mich einfach verrückt nennen und dann sind wir uns einig. Man kann es ja damit zumindest denen leichter machen die noch sowas bauen wollen und das reicht als Anreiz :)

achja: wär nett wenn du mir die Widerstände für den BD678 (BD678A ich nehme an das ist nur eine andere Bauform?!?) berechnen könntest. Also vorallem Signal-Basis und wenn du willst noch den Kollektor-Masse oder was dir da sonst noch einfällt dann könnt ich das heut noch bestellen. Also wär nett. Datenblatt gibts hier


Paul

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Fr Feb 11, 2005 2:34 pm

Hallo Paul,

dann will ich erstmal was zum Darlington-Transistor erzählen. Dabei handelt es sich um eine zusammenschaltung von zwei einzelnen Transistoren (mit zwei Widerständen) in einem Gehäuse. Damit erreicht man eine sehr viel größe Stromverstärkung und kann auch meist mehr Strom schalten. Allerdings ist der Theorie nach die Schaltzeit etwas länger, da ja beide Transistoren schalten müssen.

Im Betrieb eine Transistors als digitaler Schalter ist die Einschalt-Verzögerung kürzer als die Ausschaltverzeögerung, weil beim Einschalten der Basis-Strom den Transistor aktiv durchschaltet. Beim Abschalten ist der Basis-Strom plötzlich weg, aber es dauert eine gewisse Zeit, bis die Elektronen aus der Basis-Emitter-Strecke verschwunden sind und der Transistor wieder sperrt. Dabei hilft es, wenn ein Widerstand von der Basis zum Emitter führt, mit dem dann das Potential der Basis direkt auf das vom Emitter gezogen wird und so die restliche Ladung praktisch wieder aus der Basis rausgesaugt wird.

Ein zusätzlicher Effekt ist, dass die Transistoren eine gewisse parasitäre Kapazität aus Kollektor besitzen. Diese Kapazität wird während der Ein-Phase aufgeladen und die dort angesammelte Ladung steht auch nach dem Sperren des Transistors noch dort an. Das kann dann dazu führen, dass die dort angeschlossenen LEDs mit dieser Rest-Ladung noch kurz aufleuchten. Ein Widerstand vom Kollektor gegen Masse (bei PNP-Transistoren) kann diese Ladung ableiten, bevor die LEDs auf dem anderen Pin Strom bekommen und so das Aufleuchten verhindern.

Im Datenblatt vom BD678 finde ich leider keine Schaltverzögerung und keine Ausgangs-Kapazität. Daher kann ich leider nichts berechnen. Vermutlich ist der aber noch schlimmer als der BD238. (Warum? Gute Frage! Ist so eine Ahnung. Das Datenblatt hat ähnliche Werte, aber es ist wieder ein Darlington.)

Ich habe ein wenig herumgesucht und in einem Datenblatt eines Vergleichstyps des TIP127 gefunden, dass die Ausschaltzeit (turn-off-time) 8.5us beträgt, was natürlich viel zu viel ist und mit dem LED-Timing nie funktionieren wird, da dort nur max. 0.5us zur Verfügung stehen. Im neuen Amplifier-Timing sind es immerhin 4us, beim Latch-Timing ca. 10us.

Beim ULN2803 (enthält 8 NPN-Transistoren) ist die Ein- und Ausschaltzeit jeweils mit 1us angegeben. Es gibt den UDN2580, der 8 PNP-Transistoren enthält - aber auch dort ist die Ein- und Ausschaltzeit mit 5us zu groß. (Außerdem kann der auch nur 500mA pro Kanal - etwas zu wenig.) Anscheinend sind PNP-Transistoren langsamer als NPN-Transistoren. Das wusste ich bis eben auch noch nicht.

Ergebnis meiner Reichelt-Datenblatt-Stichproben-Suche:

Der 2N4033 hat laut Datenblatt eine Schltverzöerung von unter 200ns selbst beim Ausschalten und kann 1A dauerhaft schalten, also bestimmt auch 2A, weil er ja nur 1/20 der Zeit eingeschaltet ist. Leistungsmäßg sollte das mit dem Typ auch aus dem gleichen Grund hinhauen. Die Ausgangskapazität ist mit unter 100pF auch noch recht klein.

Widerstände:
Kleinere Werte führen zu höherem Stromverbrauch, aber geringeren Schaltzeiten. Ich würde hier jetzt mal 470Ohm vor der Basis und 220Ohm von der Basis zum Emitter vorschlagen. Damit fließen dort im Ein-Zustand ca. 10mA, was noch nicht viel ist. Im Aus-Zustand ist mit 220Ohm die Basis recht niederohmig am Emitter, was zum schnellen Abschalten führen sollte.
Für den Widerstand vom Kollektor zur Masse setzte ich hier mal 100pF und 100ns an: R = tau / C = 100ns / 100pF = 1kOhm. Damit ist die parasitäre Ausgangs-Kapazität dann in spätestens 500ns leer.
(Ja, diese Widerstände sind alle viel kleiner als im Original-Schaltplan. Da hat wohl einer nicht richtig gerechnet, sondern geraten. ;))

Ich hoffe mal, damit wird alles besser, garantieren kann ich dafür aber leider nicht. Na zumindest ist der Transistor mit 41 Cent bei Reichelt nicht so wahnsinnig teuer...

Gruß,
Stefan

zwanzischmark

Beitrag von zwanzischmark » Fr Feb 11, 2005 5:25 pm

danke erstmal für die ausführliche Antwort! Das hab ich ja alles eigentlich schon so ziemlich verstanden gehabt. Das die Darlington Transistoren 2-fach verstärkt sind war mir ja auch aufgefallen. Deshalb hab ich mich ja für den BD238 entschieden, weil ich mir dachte 2fach verstärkt = 2fach Schalten = langsam. Die Realität sah dann aber irgendwie nicht so aus denn mit dem TIP125 hatte ich ohne zusätzliche Transistoren im Latch Modus ein sauberes Bild. Mit dem BD238 hingegen mit Zusatzwiderständen gerade annähernd. Das hiess für mich dann Theorie ist eine Sache und Praxis ne andere. Ich wollte dann wenigstens einen haben der nicht schlechter ist als der TIP125 denn da vermute ich das gegenteil wie du. Darlington gegen Darlington bei gleichem Hersteller sollte doch nicht der mit der grösseren belastbarkeit gewinnen oder machen die die dinger absichtlich langsam?!?
Das du jetzt mal einen rausgesucht hast find ich natürlich auch gut ;). Kannst du mir mal nen link zum Datenblatt schicken, weil bei Reichelt ist irgendwie keins :?

Paul

Benutzeravatar
stefan
Blinkenizer
Blinkenizer
Beiträge: 234
Registriert: Mi Okt 09, 2002 9:45 pm
Wohnort: Aachen
Kontaktdaten:

Beitrag von stefan » Fr Feb 11, 2005 11:45 pm

Im Prinzip hast Du schon recht. Je weniger Leistung ein Transistor hat, desto schneller ist er.
Allerdings hängt auch ganz entscheidend die Technologie im Inneren damit zusammen. Da würde ich vemuten, dass der eine BDxxx ähnliche Technologie drin hat wie der andere BDxxx und daher auch ähnlich langsam ist...

Ein Datenblatt vom 2N4033 gibt es hier: http://www.st.com/stonline/books/pdf/docs/9041.pdf

zwanzischmark

Beitrag von zwanzischmark » Mi Feb 16, 2005 2:13 pm

so,...

Für alle die dieses Thema verfolgt haben gibt es jetzt Neuigkeiten. Die durch 1stein berechneten und durch mich getestesteten neuen Bautteile für die Zeilenverstärkung Funktionieren jetzt selbst im LED-Modus nahezu ohne Schatten. Das heisst die Schaltung besteht jetzt aus:

ULN2803 und 2N4033 mit 470 Ohm vor der Basis und 220 Ohm jeweils von der Basis zum Emitter.

Oder einfach auf den neuen Schaltplan schauen ;)


mfg Paul

EDIT by 1stein: 2N4033 eingefügt, der fehlte in der Bauteilliste
nochmal EDIT by 1stein: da stand 4k7 statt 470 Ohm, das war falsch

Benutzeravatar
cascade
BlinkenSemiProfi
BlinkenSemiProfi
Beiträge: 41
Registriert: Sa Aug 30, 2003 12:48 pm
Wohnort: Kiel
Kontaktdaten:

Beitrag von cascade » Fr Feb 18, 2005 10:43 pm

Hmm, liesst sich ja schoen, aber das problem mit den Schattenzeilen hab ich seit dem ich die Widerstaende reingeloetet hab auch nicht mehr (1stein sollte sich erinnern)...
Ich hab nur das problem das bei mir die graustufen nicht so rauskommen (sollte sich auch noch jemand dran erinnern)...
Wenn ich mir die neue schaltung antue, meinst du (1stein) man kann das timing dann auch besser einstellen / das laueft so besser?
was ich hier im querlesen verstanden habe ist das die neuen transis schneller sind, das muesste doch quasi auch heissen relativ gesehen dunkler die LEDs?!
Wenn das so ist waere es ja genau der effekt... ich hab das momentan mal versucht mit spannungsreglung zu trimmen, aber das iss auch semi optimal ;)

Und zum blauen: Haette ich mehr blaue LEDs hier gehabt haette ich meins wohl auch blau gemacht ^^

So long...
Ca$cAdE
BlinkenCUBE - AM mit 4160(+4)LEDs ^^ => Guckst du?

Antworten